您好、欢迎来到现金彩票网!
当前位置:516棋牌游戏 > 文本替换 >

易语言 批量替换文本指定内容后的数字

发布时间:2019-07-15 00:55 来源:未知 编辑:admin

  有一批批量文本文件,里面都有一句:*软荐啦9。其中所在行数不确定,数字“9”不确定,每个文件里不一样。需要批量处理,把每个文件里的这一行:*软荐啦9里的数字按我填写的倍数相乘,...

  有一批批量文本文件,里面都有一句: *软荐啦 9 。其中所在行数不确定,数字“9”不确定,每个文件里不一样。需要批量处理,把每个文件里的这一行: *软荐啦 9 里的数字按我填写的倍数相乘,并将结果写回到文件原位置。

  写了好久程序,总是发现不成功。哪怕只是先按上面的要求尝试着替换单个文件也不行。求高手指点。最好有源码提供学习!

  .子程序 _按钮1_被单击.局部变量 配置文件内容, 文本型.局部变量 文件内容数组, 文本型, , 0.局部变量 n, 整数型.局部变量 要写入的内容, 文本型.局部变量 文件号, 整数型.局部变量 寻找位置, 整数型.局部变量 文本, 文本型

  配置文件内容 = 到文本 (读入文件 (取运行目录 () + “1.cfg”))文件内容数组 = 分割文本 (配置文件内容, #换行符, ).计次循环首 (取数组成员数 (文件内容数组), n) .如果真 (取文本左边 (文件内容数组 [n], 7) = “*软荐啦”) 要写入的内容 = 取文本右边 (文件内容数组 [n], 取文本长度 (文件内容数组 [n]) - 7) 跳出循环 () .如果真结束

  .计次循环尾 ()编辑框1.内容 = 要写入的内容编辑框3.内容 = 到文本 (到数值 (编辑框1.内容) × 到数值 (编辑框2.内容))

  .如果真 (写到文件 (取运行目录 () + “”, 到字节集 (编辑框3.内容)) = 线.内容 = 要写入的内容 信息框 (“写入成功!”, 0, ).如果真结束

  .子程序 _按钮2_被单击.局部变量 文件号, 整数型.局部变量 寻找位置, 整数型.局部变量 文本, 文本型

  文件号 = 打开文件 (取运行目录 () + “1.cfg”, #读写, ).如果线.内容 ≠ “” 且 文件号 ≠ 0) 文本 = 读入文本 (文件号, ) 寻找位置 = 寻找文本 (文本, “*软荐啦”, , 假) + 1 移动读写位置 (文件号, , 寻找位置) 删除数据 (文件号, 寻找文本 (文本, “*软荐啦”, 寻找位置 + 1, 假) + 8) 移动读写位置 (文件号, , 寻找位置) 插入文本 (文件号, 编辑框3.内容) 关闭文件 (文件号).如果真结束

  可选中1个或多个下面的关键词,搜索相关资料。也可直接点“搜索资料”搜索整个问题。

  我倒是可以帮你,但我要知道(*软荐啦9)这句中间是用空格分开的,还是用TAB分开的。只有知道这个才能做出来,我测试了你的文本内容,它们中间是用了7个空格分开的。

  不过还有点问题,因为这个文件夹里有255个文件,我想想批量一次性修改。不知道在上面程序的基础上该怎么修改才能得到实现?追答你最好能把,这个文件夹包括里面的文件发给我,我才好根据各文件的实际情况分析写出代码。

  其他问题:文件夹里需要修改的文件名不同, 替换处空格也有部分不一样,发现追答

http://dolphinfixtures.com/wenbentihuan/441.html
锟斤拷锟斤拷锟斤拷QQ微锟斤拷锟斤拷锟斤拷锟斤拷锟斤拷锟斤拷微锟斤拷
关于我们|联系我们|版权声明|网站地图|
Copyright © 2002-2019 现金彩票 版权所有